$re = '/((?![\u0621-\u064A\u0660-\u0669 ]).)/mi';
$str = 'مع فيزيتا اختر بين أفضل عروض اسنان في السعودية،اختر المنطقة الأقرب لك، قارن بين اسعار العروض الطبية واحجز موعدك بسهولة';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);