$re = '/(DEBUG|INFO|WARNING|ERROR):\s(\d{2}/.+-\d{4}) (\[\w+\])\s([^:]+):\s(.+) by (.+)\s(\w+@\w+\..+)/';
$str = 'DEBUG: 01/31/2020 09:00:00 PM -0800 [ABC] meltdown occurred: stomped by George Farrel george@hotmail.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);