const regex = new RegExp('(DEBUG|INFO|WARNING|ERROR):\\s(\\d{2}/.+-\\d{4}) (\\[\\w+\\])\\s([^:]+):\\s(.+) by (.+)\\s(\\w+@\\w+\\..+)', '')
const str = `DEBUG: 01/31/2020 09:00:00 PM -0800 [ABC] meltdown occurred: stomped by George Farrel george@hotmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}