#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(DEBUG|INFO|WARNING|ERROR):\s(\d{2}/.+-\d{4}) (\[\w+\])\s([^:]+):\s(.+) by (.+)\s(\w+@\w+\..+)"
Local $sString = "DEBUG: 01/31/2020 09:00:00 PM -0800 [ABC] meltdown occurred: stomped by George Farrel george@hotmail.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")