using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(DEBUG|INFO|WARNING|ERROR):\s(\d{2}/.+-\d{4}) (\[\w+\])\s([^:]+):\s(.+) by (.+)\s(\w+@\w+\..+)";
string input = @"DEBUG: 01/31/2020 09:00:00 PM -0800 [ABC] meltdown occurred: stomped by George Farrel george@hotmail.com";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}