use strict;
my $str = 'example
http://example
https://www.example.com
http:/example.com
example.reallylongtld
https://example.com
https://ww.example.com
https://www.example.com
https://www.meetup.com/
https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/
https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/
https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399
https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/
https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/lfwnrpyxhbzb/attendees/
www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/
www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399
meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399
meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/
https://www.meetup.com/Metis-New-York-Data-Science/events/250798771/
';
my $regex = qr/^(https:\/\/)?(www\.)?(meetup\.com\/){1}[A-Za-z0-9-]{5,60}(\/events\/){1}[A-Za-z0-9-]+(\/)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}