const regex = /^(https:\/\/)?(www\.)?(meetup\.com\/){1}[A-Za-z0-9-]{5,60}(\/events\/){1}[A-Za-z0-9-]+(\/)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https:\\\/\\\/)?(www\\.)?(meetup\\.com\\\/){1}[A-Za-z0-9-]{5,60}(\\\/events\\\/){1}[A-Za-z0-9-]+(\\\/)?$', 'gm')
const str = `example
http://example
https://www.example.com
http:/example.com
example.reallylongtld
https://example.com
https://ww.example.com
https://www.example.com
https://www.meetup.com/
https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/
https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/
https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399
https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/
https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/lfwnrpyxhbzb/attendees/
www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/
www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399
meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399
meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/
https://www.meetup.com/Metis-New-York-Data-Science/events/250798771/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}