import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https:\\/\\/)?(www\\.)?(meetup\\.com\\/){1}[A-Za-z0-9-]{5,60}(\\/events\\/){1}[A-Za-z0-9-]+(\\/)?$";
final String string = "example\n"
+ "http://example\n"
+ "https://www.example.com\n"
+ "http:/example.com\n"
+ "example.reallylongtld\n"
+ "https://example.com\n"
+ "https://ww.example.com\n"
+ "https://www.example.com\n"
+ "https://www.meetup.com/\n"
+ "https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/\n"
+ "https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/\n"
+ "https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399\n"
+ "https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/\n"
+ "https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/lfwnrpyxhbzb/attendees/\n"
+ "www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/\n"
+ "www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399\n"
+ "meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399\n"
+ "meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/\n"
+ "https://www.meetup.com/Metis-New-York-Data-Science/events/250798771/\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}