package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https:\/\/)?(www\.)?(meetup\.com\/){1}[A-Za-z0-9-]{5,60}(\/events\/){1}[A-Za-z0-9-]+(\/)?$`)
var str = `example
http://example
https://www.example.com
http:/example.com
example.reallylongtld
https://example.com
https://ww.example.com
https://www.example.com
https://www.meetup.com/
https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/
https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/
https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399
https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/
https://www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/lfwnrpyxhbzb/attendees/
www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/
www.meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399
meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399
meetup.com/Bay-Area-Women-in-Machine-Learning-and-Data-Science/events/250528399/
https://www.meetup.com/Metis-New-York-Data-Science/events/250798771/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}