$re = '/<(a\shref)="\w{4,5}:\/\/\w+.\w{2}">\w+(<\/a>)/';
$str = '<ul> <li> <a href="http://softuni.bg">SoftUni</a></li></ul>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);