const regex = /<(a\shref)="\w{4,5}:\/\/\w+.\w{2}">\w+(<\/a>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(a\\shref)="\\w{4,5}:\\\/\\\/\\w+.\\w{2}">\\w+(<\\\/a>)', 'g')
const str = `<ul> <li> <a href="http://softuni.bg">SoftUni</a></li></ul>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}