using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(a\shref)=""\w{4,5}:\/\/\w+.\w{2}"">\w+(<\/a>)";
string input = @"<ul> <li> <a href=""http://softuni.bg"">SoftUni</a></li></ul>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}