package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<(a\shref)="\w{4,5}:\/\/\w+.\w{2}">\w+(<\/a>)`)
var str = `<ul> <li> <a href="http://softuni.bg">SoftUni</a></li></ul>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}