// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^<(?i)(?:input|textarea|\\w{0,}TextBox|\\w{0,}Field).*(?:name|id)=(?:\"|\')\w+(?:\"|\').*"#).unwrap();
let string = "{{! my-form.hbs }}
<form onsubmit={{action \"submit\"}}>
<label for=\"name\">Name:</label>
<input type=\"text\" id=\"name\" value={{model.name}}>
<label for=\"email\">Email:</label>
<input type=\"email\" id=\"email\" value={{model.email}}>
<label for=\"message\">Message:</label>
<textarea id=\"message\">{{model.message}}</textarea>
<button type=\"submit\">Submit</button>
</form>
<html>
<head>
<title>My Form</title>
</head>
<body>
<form>
<label for=\"name\">Name:</label>
<input type=\"text\" name=\"name\" id=\"name\"/>
<label for=\"email\">Email:</label>
<input type=\"email\" name=\"email\" id=\"email\"/>
<label for=\"message\">Message:</label>
<textarea name=\"message\" id=\"message\"></textarea>
<button type=\"button\" onclick=\"submitForm()\">Submit</button>
</form>
</body>
</html>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}