$re = '/^<(?i)(?:input|textarea|\\\\w{0,}TextBox|\\\\w{0,}Field).*(?:name|id)=(?:\"|\')\w+(?:\"|\').*/m';
$str = '{{! my-form.hbs }}
<form onsubmit={{action "submit"}}>
<label for="name">Name:</label>
<input type="text" id="name" value={{model.name}}>
<label for="email">Email:</label>
<input type="email" id="email" value={{model.email}}>
<label for="message">Message:</label>
<textarea id="message">{{model.message}}</textarea>
<button type="submit">Submit</button>
</form>
<html>
<head>
<title>My Form</title>
</head>
<body>
<form>
<label for="name">Name:</label>
<input type="text" name="name" id="name"/>
<label for="email">Email:</label>
<input type="email" name="email" id="email"/>
<label for="message">Message:</label>
<textarea name="message" id="message"></textarea>
<button type="button" onclick="submitForm()">Submit</button>
</form>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);