const regex = /^<(?i)(?:input|textarea|\\w{0,}TextBox|\\w{0,}Field).*(?:name|id)=(?:\"|\')\w+(?:\"|\').*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^<(?i)(?:input|textarea|\\\\w{0,}TextBox|\\\\w{0,}Field).*(?:name|id)=(?:\\"|\\\')\\w+(?:\\"|\\\').*', 'gm')
const str = `{{! my-form.hbs }}
<form onsubmit={{action "submit"}}>
<label for="name">Name:</label>
<input type="text" id="name" value={{model.name}}>
<label for="email">Email:</label>
<input type="email" id="email" value={{model.email}}>
<label for="message">Message:</label>
<textarea id="message">{{model.message}}</textarea>
<button type="submit">Submit</button>
</form>
<html>
<head>
<title>My Form</title>
</head>
<body>
<form>
<label for="name">Name:</label>
<input type="text" name="name" id="name"/>
<label for="email">Email:</label>
<input type="email" name="email" id="email"/>
<label for="message">Message:</label>
<textarea name="message" id="message"></textarea>
<button type="button" onclick="submitForm()">Submit</button>
</form>
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}