use strict;
my $str = '{{! my-form.hbs }}
<form onsubmit={{action "submit"}}>
<label for="name">Name:</label>
<input type="text" id="name" value={{model.name}}>
<label for="email">Email:</label>
<input type="email" id="email" value={{model.email}}>
<label for="message">Message:</label>
<textarea id="message">{{model.message}}</textarea>
<button type="submit">Submit</button>
</form>
<html>
<head>
<title>My Form</title>
</head>
<body>
<form>
<label for="name">Name:</label>
<input type="text" name="name" id="name"/>
<label for="email">Email:</label>
<input type="email" name="email" id="email"/>
<label for="message">Message:</label>
<textarea name="message" id="message"></textarea>
<button type="button" onclick="submitForm()">Submit</button>
</form>
</body>
</html>';
my $regex = qr/^<(?i)(?:input|textarea|\\w{0,}TextBox|\\w{0,}Field).*(?:name|id)=(?:\"|\')\w+(?:\"|\').*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}