import Foundation
let pattern = ##"^(?<local>[a-zA-Z0-9\.!#$%&'*\-\/=?^_`{|}~"]+)(?:\.)?(?<routing>[a-zA-Z0-9\.!#$%&'*\-\/=?^_`{|}~+"]*)(?:@)(?<domain>(?:[a-zA-Z0-9\-[\]]*)(?:\.)(?:[a-zA-Z0-9\-[\]\.]*))$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
yemolai+hello+amps@gmail.com
romulogabriel@outlook.com.br
a13b3440.junior@gmail.jp
gabriel.rodrigues@sedop.pa.gov.br
rubens.junior00k@hotmail-p.com
adam.mills@[192.168.1.1]
a@B.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)