import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<local>[a-zA-Z0-9\\.!#$%&'*\\-\\/=?^_`\\{|\\}~\"]+)(?:\\.)?(?<routing>[a-zA-Z0-9\\.!#$%&'*\\-\\/=?^_`\\{|\\}~+\"]*)(?:@)(?<domain>(?:[a-zA-Z0-9\\-[\\]]*)(?:\\.)(?:[a-zA-Z0-9\\-[\\]\\.]*))$";
final String string = "yemolai+hello+amps@gmail.com\n"
+ "romulogabriel@outlook.com.br\n"
+ "a13b3440.junior@gmail.jp\n"
+ "gabriel.rodrigues@sedop.pa.gov.br\n"
+ "rubens.junior00k@hotmail-p.com\n"
+ "adam.mills@[192.168.1.1]\n"
+ "a@B.com\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}