re = /^(?<local>[a-zA-Z0-9\.!#$%&'*\-\/=?^_`{|}~"]+)(?:\.)?(?<routing>[a-zA-Z0-9\.!#$%&'*\-\/=?^_`{|}~+"]*)(?:@)(?<domain>(?:[a-zA-Z0-9\-[\]]*)(?:\.)(?:[a-zA-Z0-9\-[\]\.]*))$/m
str = 'yemolai+hello+amps@gmail.com
romulogabriel@outlook.com.br
a13b3440.junior@gmail.jp
gabriel.rodrigues@sedop.pa.gov.br
rubens.junior00k@hotmail-p.com
adam.mills@[192.168.1.1]
a@B.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end