const regex = /^(?<local>[a-zA-Z0-9\.!#$%&'*\-\/=?^_`{|}~"]+)(?:\.)?(?<routing>[a-zA-Z0-9\.!#$%&'*\-\/=?^_`{|}~+"]*)(?:@)(?<domain>(?:[a-zA-Z0-9\-[\]]*)(?:\.)(?:[a-zA-Z0-9\-[\]\.]*))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<local>[a-zA-Z0-9\\.!#$%&\'*\\-\\\/=?^_`{|}~"]+)(?:\\.)?(?<routing>[a-zA-Z0-9\\.!#$%&\'*\\-\\\/=?^_`{|}~+"]*)(?:@)(?<domain>(?:[a-zA-Z0-9\\-[\\]]*)(?:\\.)(?:[a-zA-Z0-9\\-[\\]\\.]*))$', 'gm')
const str = `yemolai+hello+amps@gmail.com
romulogabriel@outlook.com.br
a13b3440.junior@gmail.jp
gabriel.rodrigues@sedop.pa.gov.br
rubens.junior00k@hotmail-p.com
adam.mills@[192.168.1.1]
a@B.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}