import Foundation
let pattern = #"^(?<baseURL>https?:\/\/.+?)(?:\/(?:party(?:\/(?<partyId>[^/]+)(?:\/(?<partyView>game|results)?)?)?)?)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://wikirace.example.org
https://wikirace.example.org/
https://wikirace.example.org/party/asdfghj
https://wikirace.example.org/party/asdfghj/game
https://wikirace.example.org/party/asdfghj/results
https://example.org/wikirace/
http://example.org/wikirace/party
http://example.org/wikirace/game
https://wikirace.example.org/game/fghjhkl
https://example.org/wikirace/game/fghjhkl
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)