import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<baseURL>https?:\\/\\/.+?)(?:\\/(?:party(?:\\/(?<partyId>[^/]+)(?:\\/(?<partyView>game|results)?)?)?)?)?$";
final String string = "http://wikirace.example.org\n"
+ "https://wikirace.example.org/\n"
+ "https://wikirace.example.org/party/asdfghj\n"
+ "https://wikirace.example.org/party/asdfghj/game\n"
+ "https://wikirace.example.org/party/asdfghj/results\n\n"
+ "https://example.org/wikirace/\n"
+ "http://example.org/wikirace/party\n"
+ "http://example.org/wikirace/game\n"
+ "https://wikirace.example.org/game/fghjhkl\n"
+ "https://example.org/wikirace/game/fghjhkl";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}