package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<baseURL>https?:\/\/.+?)(?:\/(?:party(?:\/(?<partyId>[^/]+)(?:\/(?<partyView>game|results)?)?)?)?)?$`)
var str = `http://wikirace.example.org
https://wikirace.example.org/
https://wikirace.example.org/party/asdfghj
https://wikirace.example.org/party/asdfghj/game
https://wikirace.example.org/party/asdfghj/results
https://example.org/wikirace/
http://example.org/wikirace/party
http://example.org/wikirace/game
https://wikirace.example.org/game/fghjhkl
https://example.org/wikirace/game/fghjhkl`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}