#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<baseURL>https?:\/\/.+?)(?:\/(?:party(?:\/(?<partyId>[^/]+)(?:\/(?<partyView>game|results)?)?)?)?)?$"
Local $sString = "http://wikirace.example.org" & @CRLF & _
"https://wikirace.example.org/" & @CRLF & _
"https://wikirace.example.org/party/asdfghj" & @CRLF & _
"https://wikirace.example.org/party/asdfghj/game" & @CRLF & _
"https://wikirace.example.org/party/asdfghj/results" & @CRLF & _
"" & @CRLF & _
"https://example.org/wikirace/" & @CRLF & _
"http://example.org/wikirace/party" & @CRLF & _
"http://example.org/wikirace/game" & @CRLF & _
"https://wikirace.example.org/game/fghjhkl" & @CRLF & _
"https://example.org/wikirace/game/fghjhkl"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")