# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"auf\s+(?:dem|ihrem)\s+Schild\s+(\S+\s+)*(?:darstellte|dargestellt)"
test_str = ("Plinius, Naturalis historia 34,54 (= DNO 905)\n"
"Phidias schuf außer dem Zeus von Olympia, dem niemand den Rang streitig macht,\n"
"ebenfalls aus Elfenbein eine <Statue der> Athena in Athen, die sich im Parthenon\n"
"befindet, aufrecht stehend <dargestellt>.\n\n"
"Plinius, Naturalis historia 36,18 (= DNO 906)\n"
"Dass Phidias als berühmtester <Künstler> bei allen Völkern gilt, bis zu denen der Ruf\n"
"seines olympischen Zeus gelangt ist, bezweifelt niemand; damit aber auch diejenigen,\n"
"die seine Werke nicht gesehen haben, wissen, dass man ihn verdientermaßen rühmt,\n"
"wollen wir kleine Belege anführen, und zwar nur solche, die seine Erfindungsgabe\n"
"beweisen. Wir werden dazu nicht die Schönheit seines olympischen Zeus, nicht die\n"
"Größe seiner in Athen geschaffenen Athena, obgleich diese 26 Ellen hoch ist - sie\n"
"besteht bekanntlich aus Elfenbein und Gold - heranziehen, sondern <nur erwähnen>,\n"
"dass er auf ihrem Schild am konvexen <äußeren> Rund die Amazonenschlacht, im\n"
"konkaven Teil die Kämpfe der Götter und Giganten, an den Sandalen aber die der\n"
"Lapithen und Kentauren dargestellt hat. Jedes Detail bot ihm Anlass für kunstvolle\n"
"Darstellung. Das Relief auf dem Sockel aber nennt man Pandoras Genesis (die\n"
"Geburt der Pandora): Zwanzig Gottheiten sind bei der Geburt zugegen. Seine Nike ist\n"
"vor allem bemerkenswert; Kenner bewundern aber auch die Schlange und die eherne\n"
"Sphinx (am Helm) unterhalb der Speerspitze. Diese beiläufigen Bemerkungen über\n"
"den niemals genug gelobten Künstler mögen ausreichen, damit man zugleich\n"
"erkenne, dass sich jene (sc. des Phidias) großartige künstlerische Begabung auch in\n"
"kleinen Gegenständen gleichermaßen zeigte.\n\n"
"Thukydides 2,13 (= DNO 894)\n"
"Ferner rechnete er (Perikles) die nicht unbedeutenden Reichtümer aus den anderen\n"
"Heiligtümern hinzu, die sie verwenden könnten, und wenn sie völlig von allem\n"
"abgeschnitten würden, auch das Gold, womit die Göttin selbst bekleidet war, und er\n"
"wies darauf hin, dass die Statue 40 Talente pures Gold an sich trage und alles rundum\n"
"abnehmbar sei.\n\n"
"Scholion zu Demosthenes or. 22,13 (= DNO 876)\n"
"Der Parthenon war der Tempel der Athena Parthenos auf der Akropolis und mit dem\n"
"Standbild (agalma) der Göttin, das der Bildhauer (andriantoplastes) Phidias aus Gold\n"
"und Elfenbein angefertigt hatte. Es gab nämlich drei Standbilder (agalmata) der\n"
"Athena auf der Akropolis an unterschiedlichen Orten: Eines stammte aus der Frühzeit\n"
"und war aus Olivenbaumholz; dies wurde Athena Polias genannt, weil <Athen> die\n"
"Stadt (polis) der Athena war. Das zweite war ganz aus Bronze; dies hatten die Sieger\n"
"von Marathon anfertigen lassen und es wurde Athena Promachos (Vorkämpferin)\n"
"genannt. Das dritte ließen sie aus Gold und Elfenbein errichten, weil sie reicher\n"
"geworden waren nach dem Sieg bei Salamis, in dem Maße wie auch der Sieg <bei\n"
"Salamis> größer war <als der bei Marathon>; dies wurde Athena Parthenos genannt.\n\n"
"Scholion zu Aristophanes Pax 605a (= DNO 923)\n"
"Philochoros berichtet aus dem Archontat des Pythodoros (438/37 v. Chr.) folgendes:\n"
"Es wurde auch die goldene Statue (agalma) der Athena in dem großen Tempel\n"
"(Parthenon) aufgestellt, die Gold im Gewicht von 44 Talenten an sich trug; die Leitung\n"
"lag bei Perikles und die Ausführung bei Phidias. Da der Künstler Phidias in den\n"
"Verdacht geriet, das Elfenbein für den Panzer falsch abgerechnet zu haben, wurde er\n"
"angeklagt. Es heißt, er sei nach Elis geflohen/verbannt worden, habe dort den Auftrag\n"
"für die Statue des Zeus in Olympia übernommen, sei aber, nachdem er diese\n"
"fertiggestellt habe, von den Eieern umgebracht worden.\n\n"
"Dion von Prusa, or. 12,6 (= DNO 910)\n"
"Von Athena, der Schönsten und Klügsten unter den Göttern, sagt man, ihr sei dieser\n"
"Vogel (Eule) besonders lieb gewesen. Die Eule kam denn auch bei den Athenern in\n"
"den Genuss der Kunstfertigkeit des Phidias, der sie mit Zustimmung des Volkes nicht\n"
"für unwürdig hielt, der Göttin als Attribut beizugeben, während er Perikles und sich\n"
"selbst, wie man sagt, nur versteckt auf dem Schild darstellte.\n\n"
"Valerius Maximus, Facta et dicta memorabilia 1,1 ext.7 (= DNO 903)\n"
"Dieselben (sc. die Athener) rühmten den Phidias, obwohl er sagte, dass die Minerva\n"
"eher aus Marmor als aus Elfenbein gemacht werden müsse, weil so der Glanz länger\n"
"erhalten bleibe; als er aber hinzufügte, dass es auch billiger sei, hießen sie ihn still zu\n"
"sein.\n\n"
"Platon, Hippias maior 290a-c (= DNO 895)\n"
"Sokrates: Und doch wird er diese Antwort nicht nur nicht gelten lassen, mein Bester,\n"
"sondern er wird sich noch recht lustig über mich machen und sagen: \"Du, Hohlkopf,\n"
"hältst du etwa Phidias für einen schlechten Künstler?\" Und ich werde dann wohl\n"
"erwidern, das sei keineswegs der Fall.\n"
"Hippias: Womit du auch recht hast, Sokrates.\n"
"Sokrates: Allerdings. Aber wenn ich <ihm> dann zustimmt habe, dass Phidias ein\n"
"trefflicher Künstler ist, wird jener sagen: Und du glaubst also, dass Phidias das, was\n"
"du als das Schöne bestimmst, nicht gekannt habe? - Da werde ich fragen: Wieso\n"
"denn das? - Weil er, so wird er antworten, seiner Athena die Augen nicht golden\n"
"gemacht hat, und auch sonst weder das Gesicht noch Hände noch Füße, wo es doch\n"
"golden am schönsten erschienen wäre, sondern elfenbeinern. Offenbar hat er diesen\n"
"Fehler aus Unkenntnis gemacht, weil er nicht wusste, dass Gold das ist, was alles\n"
"schön macht, wohin es auch kommt. Wenn er nun das sagt, was sollen wir ihm\n"
"antworten, Hippias?\n"
"Hippias: Das ist nicht schwer. Wir wollen sagen, er hätte recht getan. Denn auch\n"
"Elfenbeinernes, denke ich, ist schön.\n"
"Sokrates: Weshalb aber, wird er dann sagen, hat er nicht das Innere der Augen auch\n"
"aus Elfenbein gemacht, sondern aus Stein, wobei er einen aussuchte, der dem\n"
"Elfenbein möglichst ähnlich war? Oder ist auch der Stein, der schöne jedenfalls,\n"
"etwas Schönes? Werden wir das sagen, Hippias?\n\n"
"Ps.-Aristoteles, De mundo 6,399b (= DNO 911)\n"
"Man erzählt, dass auch der Bildhauer Phidias, als er die Athena auf der Akropolis\n"
"schuf, in der Mitte ihres Schildes sein eigenes Porträt angebracht und durch eine\n"
"geheime Vorrichtung so mit dem Standbild (agalma) verbunden habe, dass, wenn\n"
"jemand es herausnehmen wollte, zwangsläufig das ganze Kunstwerk (agalma)\n"
"auseinanderbrechen und zusammenstürzen musste.\n\n"
"Pausanias 1,24,5–7 (= DNO 892)\n"
"Tritt man in den Tempel ein, den man Parthenon nennt, so bezieht sich die ganze\n"
"Darstellung im <Ost->Giebel auf die Geburt der Athena, der rückwärtige < West-\n"
">Giebel zeigt den Streit des Poseidon mit Athena um das Land. Die Kultstatue\n"
"(ágalma) selbst ist aus Gold und Elfenbein gemacht. Mitten auf ihrem Helm sitzt die\n"
"Figur (eikon) einer Sphinx - was man von der Sphinx erzählt, werde ich schreiben,\n"
"wenn meine Darstellung Böotien erreicht hat -, beiderseits an dem Helm aber sind\n"
"Greifen angearbeitet. (6) [ ... Exkurs zu den Greifen ... ] (7) Über die Greifen mag dies\n"
"genügen. Die Kultstatue (ágalma) der Athena steht aufrecht und ist mit einem Chiton\n"
"bis zu den Füßen <bekleidet>, und auf ihrer Brust ist das Medusenhaupt aus\n"
"Elfenbein angebracht. Und eine Nike (Siegesgöttin), gegen vier Ellen hoch, hält sie\n"
"und in der <anderen> Hand hat sie eine Lanze und zu ihren Füßen steht ein Schild,\n"
"und neben der Lanze befindet sich eine Schlange, und diese Schlange dürfte\n"
"Erichthonios sein. An der Basis des Kultbildes ist die Geburt der Pandora (Pandaras\n"
"genesis) dargestellt. Hesiod und andere haben erzählt, wie diese Pandora die erste\n"
"Frau wurde; vor der Geburt der Pandora gab es das Geschlecht der Frauen noch\n"
"nicht. Hier steht sonst nur eine Statue (eíkon) des Kaisers Hadrian, wie ich selbst\n"
"gesehen habe, und am Eingang eine des Iphikrates, der viele bewundernswerte Taten\n"
"vollbracht hat.\n\n"
"Plutarch, Perikles 31,2–5 (= DNO 855)\n"
"Das Übelste aber, was als Kriegsursache angeführt und von sehr vielen Zeugen\n"
"bestätigt wird, ist dies: Die Anfertigung der Athenastatue hatte, wie schon erwähnt, der\n"
"Bildhauer Phidias übernommen, der mit Perikles befreundet war und großen Einfluss\n"
"bei ihm hatte. Dieser hatte sich schon selber Feinde gemacht, die ihm den Ruhm\n"
"neideten; andere wollten, indem sie ihn angriffen, das Volk auf die Probe stellen <und\n"
"feststellen>, wie es sich bei einer Anklage gegen Perikles verhalten würde. Sie\n"
"überredeten Menon, einen von Phidias' Gehilfen, sich als Schutzflehender auf den\n"
"Markt zu setzen und um Sicherheit zu bitten, da er Phidias anzeigen und Klage gegen\n"
"ihn erheben wolle. Als das Volk ihm das gewünschte Versprechen gegeben hatte und\n"
"vor der Volksversammlung Anklage erhoben worden war, konnte der Vorwurf der\n"
"Unterschlagung nicht bewiesen werden, denn Phidias hatte das Gold auf Perikles' Rat\n"
"gleich von Anfang an so geschickt ringsum an dem Götterbild (agalma) angebracht,\n"
"dass es ganz abgenommen und sein Gewicht nachgeprüft werden konnte, was\n"
"Perikles denn auch damals die Ankläger tun hieß. Es war jedoch <in Wahrheit> der\n"
"Ruhm seiner Werke, der durch den Neid, den er auslöste, Phidias in Schwierigkeit\n"
"brachte, und ganz besonders die Tatsache, dass er sich selber abbildete, als er den\n"
"Amazonenkampf auf dem Schilde der Göttin schuf, und zwar in der Gestalt eines\n"
"kahlköpfigen Alten, welcher mit beiden Händen einen Stein in die Höhe hebt, und\n"
"dass er überdies ein vortreffliches Bildnis des Perikles, wie er mit einer Amazone\n"
"kämpft, in die Darstellung einfügte. Von besonderer Raffinesse zeugt die Haltung der\n"
"rechten Hand <der Amazone>, die einen Speer vor Perikles' Gesicht hält. Es ist, als habe Phidias damit die Ähnlichkeit verdecken wollen, die aber von beiden Seiten her\n"
"deutlich in die Augen fällt. Phidias wurde ins Gefängnis geworfen, wo er an einer\n"
"Krankheit oder, wie einige behaupten, an Gift starb, das ihm die Feinde des Perikles\n"
"gebracht hatten, um diesen zu verleumden. Dem Menon aber, der ihn angezeigt hatte,\n"
"verlieh das Volk auf Glykons Antrag Abgabenfreiheit und beauftragte zugleich die\n"
"Feldherrn, für seine Sicherheit Sorge zu tragen.\n\n"
"Plutarch, Perikles 13,14 (160c) (= DNO 907)\n"
"Phidias selbst schuf das goldene Standbild (hédos) der Athene; er wird auch in einer\n"
"Inschrift auf der Stele als Schöpfer des Werks genannt.\n\n"
"Isokrates, Or. 15,2 (DNO 896)\n"
"Ich weiß, dass es einige Sophisten meine Beschäftigungen verleumden und sagen, es\n"
"gehe nur um das Schreiben von Gerichtsreden, und sich damit so verhalten, wie wenn\n"
"es einer wagte, Phidias, den Schöpfer der Athena <Parthenos>, als Bildner von\n"
"Tonfigürchen zu bezeichen, oder behauptete, Zeuxis und Parrhasios übten die gleiche\n"
"Kunst aus wie die Maler von Votivbildchen.\n\n"
"Cicero, Orator 234 (DNO 899)\n"
"Falls aber jemand an einer lockeren Form mehr Gefallen findet, so wende er sie nur\n"
"an – jedoch so, wie jemand den Schild des Phidias auseinandernimmt und <so> zwar\n"
"die Gesamtstruktur auflöst, nicht aber die Schönheit der Einzelheiten.\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.