use strict;
my $str = 'stackoverflow.com/story/razvan-ciocanel
cv/jmwicks
http://stackoverflow.com/cv/razvan-ciocanel
http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel?tab=profile
http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel
http://stackoverflow.com/story/razvan-ciocanel
stackoverflow.com/story/razvan-ciocanel
/story/razvan-ciocanel
users/2141313/jmwicks
users/2141313/jmwicks/
/users/2141313/jmwicks
/users/2141313/jmwicks/
cv/jmwicks
/cv/jmwicks
/cv/jmwicks/
';
my $regex = qr/(^(?:stackoverflow\.com)?[\/]*([cv|users|story]?[\/\w\-\.]*)$)|(^(?:http?:\/\/|https?:\/\/)?(?:www\.)?stackoverflow\.com\/(?:\/*)([\w\-\.\/\%]*))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}