package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^(?:stackoverflow\.com)?[\/]*([cv|users|story]?[\/\w\-\.]*)$)|(^(?:http?:\/\/|https?:\/\/)?(?:www\.)?stackoverflow\.com\/(?:\/*)([\w\-\.\/\%]*))`)
var str = `stackoverflow.com/story/razvan-ciocanel
cv/jmwicks
http://stackoverflow.com/cv/razvan-ciocanel
http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel?tab=profile
http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel
http://stackoverflow.com/story/razvan-ciocanel
stackoverflow.com/story/razvan-ciocanel
/story/razvan-ciocanel
users/2141313/jmwicks
users/2141313/jmwicks/
/users/2141313/jmwicks
/users/2141313/jmwicks/
cv/jmwicks
/cv/jmwicks
/cv/jmwicks/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}