import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(?:stackoverflow\\.com)?[\\/]*([cv|users|story]?[\\/\\w\\-\\.]*)$)|(^(?:http?:\\/\\/|https?:\\/\\/)?(?:www\\.)?stackoverflow\\.com\\/(?:\\/*)([\\w\\-\\.\\/\\%]*))";
final String string = "stackoverflow.com/story/razvan-ciocanel\n"
+ "cv/jmwicks\n"
+ "http://stackoverflow.com/cv/razvan-ciocanel\n"
+ "http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel?tab=profile\n"
+ "http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel\n"
+ "http://stackoverflow.com/story/razvan-ciocanel\n"
+ "stackoverflow.com/story/razvan-ciocanel\n"
+ "/story/razvan-ciocanel\n"
+ "users/2141313/jmwicks\n"
+ "users/2141313/jmwicks/\n"
+ "/users/2141313/jmwicks\n"
+ "/users/2141313/jmwicks/\n"
+ "cv/jmwicks\n"
+ "/cv/jmwicks\n"
+ "/cv/jmwicks/\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}