import Foundation
let pattern = #"public\s+(.+):([^,]+),?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
public typeface:Typeface,
public weight:FontWeight,
public color:Color,
public size:Units,
public line:Units,
public character:Units,
public fontStyle:ABoolean,
public decorationUnderline:ABoolean,
public decorationCrossed:ABoolean,
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"this.$1 = $1;"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)