const regex = /public\s+(.+):([^,]+),?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('public\\s+(.+):([^,]+),?', 'g')
const str = `
public typeface:Typeface,
public weight:FontWeight,
public color:Color,
public size:Units,
public line:Units,
public character:Units,
public fontStyle:ABoolean,
public decorationUnderline:ABoolean,
public decorationCrossed:ABoolean,
`;
const subst = `this.$1 = $1;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);