package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`public\s+(.+):([^,]+),?`)
var str = `
public typeface:Typeface,
public weight:FontWeight,
public color:Color,
public size:Units,
public line:Units,
public character:Units,
public fontStyle:ABoolean,
public decorationUnderline:ABoolean,
public decorationCrossed:ABoolean,
`
var substitution = "this.$1 = $1;"
fmt.Println(re.ReplaceAllString(str, substitution))
}