#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "public\s+(.+):([^,]+),?"
Local $sString = "" & @CRLF & _
" public typeface:Typeface," & @CRLF & _
" public weight:FontWeight," & @CRLF & _
" public color:Color," & @CRLF & _
" public size:Units," & @CRLF & _
" public line:Units," & @CRLF & _
" public character:Units," & @CRLF & _
" public fontStyle:ABoolean," & @CRLF & _
" public decorationUnderline:ABoolean," & @CRLF & _
" public decorationCrossed:ABoolean," & @CRLF & _
" "
Local $sSubst = "this.$1 = $1;"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)