re = /(^NHL\..*?(\.at\.|\.vs\.).*?(720p|820p).*?WEB\.(h|H)264-(SENDiT|GORE))/m
str = 'NHL.2020.03.11.New.York.Rangers.vs.Colorado.Avalanche.720p.WEB.H264-SENDiT
NHL.2020.02.19.New.York.Rangers.vs.Chicago.Blackhawks.720p.WEB.h264-GORE
NHL.2019.11.20.Washington.Capitals.vs.New.York.Rangers.720p.WEB.h264-GORE-Obfuscated
NHL.2019.11.10.Florida.Panthers.vs.New.York.Rangers.720p.WEB.h264-GORE-Obfuscated
NHL.2019.11.06.Detroit.Red.Wings.at.New.York.Rangers.720p.WEB.h264-GORE-Obfuscated
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end