#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^NHL\..*?(\.at\.|\.vs\.).*?(720p|820p).*?WEB\.(h|H)264-(SENDiT|GORE))"
Local $sString = "NHL.2020.03.11.New.York.Rangers.vs.Colorado.Avalanche.720p.WEB.H264-SENDiT" & @CRLF & _
"NHL.2020.02.19.New.York.Rangers.vs.Chicago.Blackhawks.720p.WEB.h264-GORE" & @CRLF & _
"NHL.2019.11.20.Washington.Capitals.vs.New.York.Rangers.720p.WEB.h264-GORE-Obfuscated" & @CRLF & _
"NHL.2019.11.10.Florida.Panthers.vs.New.York.Rangers.720p.WEB.h264-GORE-Obfuscated" & @CRLF & _
"NHL.2019.11.06.Detroit.Red.Wings.at.New.York.Rangers.720p.WEB.h264-GORE-Obfuscated" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")