# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^NHL\..*?(\.at\.|\.vs\.).*?(720p|820p).*?WEB\.(h|H)264-(SENDiT|GORE))"
test_str = ("NHL.2020.03.11.New.York.Rangers.vs.Colorado.Avalanche.720p.WEB.H264-SENDiT\n"
"NHL.2020.02.19.New.York.Rangers.vs.Chicago.Blackhawks.720p.WEB.h264-GORE\n"
"NHL.2019.11.20.Washington.Capitals.vs.New.York.Rangers.720p.WEB.h264-GORE-Obfuscated\n"
"NHL.2019.11.10.Florida.Panthers.vs.New.York.Rangers.720p.WEB.h264-GORE-Obfuscated\n"
"NHL.2019.11.06.Detroit.Red.Wings.at.New.York.Rangers.720p.WEB.h264-GORE-Obfuscated\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.