using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^NHL\..*?(\.at\.|\.vs\.).*?(720p|820p).*?WEB\.(h|H)264-(SENDiT|GORE))";
string input = @"NHL.2020.03.11.New.York.Rangers.vs.Colorado.Avalanche.720p.WEB.H264-SENDiT
NHL.2020.02.19.New.York.Rangers.vs.Chicago.Blackhawks.720p.WEB.h264-GORE
NHL.2019.11.20.Washington.Capitals.vs.New.York.Rangers.720p.WEB.h264-GORE-Obfuscated
NHL.2019.11.10.Florida.Panthers.vs.New.York.Rangers.720p.WEB.h264-GORE-Obfuscated
NHL.2019.11.06.Detroit.Red.Wings.at.New.York.Rangers.720p.WEB.h264-GORE-Obfuscated
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}