$re = '/^(\d{1,3}\.){3}\d{1,3}\/\d{1,2}/m';
$str = '192.168.23.10/27
10.57.5.253/23
xxx.34.19.78/18
172.z6.10.1/21
10.57.4.35
172.16.10.1/20
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);