use strict;
my $str = '192.168.23.10/27
10.57.5.253/23
xxx.34.19.78/18
172.z6.10.1/21
10.57.4.35
172.16.10.1/20
';
my $regex = qr/^(\d{1,3}\.){3}\d{1,3}\/\d{1,2}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}