package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{1,3}\.){3}\d{1,3}\/\d{1,2}`)
var str = `192.168.23.10/27
10.57.5.253/23
xxx.34.19.78/18
172.z6.10.1/21
10.57.4.35
172.16.10.1/20
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}