const regex = /^(\d{1,3}\.){3}\d{1,3}\/\d{1,2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{1,3}\\.){3}\\d{1,3}\\\/\\d{1,2}', 'gm')
const str = `192.168.23.10/27
10.57.5.253/23
xxx.34.19.78/18
172.z6.10.1/21
10.57.4.35
172.16.10.1/20
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}