re = /^([<>=!]?)\s?((?:\d*\.)?\d+)\s?(.*)$/m
str = '< 2 Mbps
> 2 Mbps
! 2 Mbps
<2 Mbps
>2 Mbps
!2 Mbps
<2Mbps
>2Mbps
!2Mbps
< 1.5 Mbps
> 1.5 Mbps
! 1.5 Mbps
<1.5 Mbps
>1.5 Mbps
!1.5 Mbps
<1.5Mbps
>1.5Mbps
!1.5Mbps
< 1.5 Mbps
< 1.5 M
< 1.5 Kbps
< 1.5 K
2 Mbps
2Mbps
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end