import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([<>=!]?)\\s?((?:\\d*\\.)?\\d+)\\s?(.*)$";
final String string = "< 2 Mbps\n"
+ "> 2 Mbps\n"
+ "! 2 Mbps\n"
+ "<2 Mbps\n"
+ ">2 Mbps\n"
+ "!2 Mbps\n"
+ "<2Mbps\n"
+ ">2Mbps\n"
+ "!2Mbps\n\n"
+ "< 1.5 Mbps\n"
+ "> 1.5 Mbps\n"
+ "! 1.5 Mbps\n"
+ "<1.5 Mbps\n"
+ ">1.5 Mbps\n"
+ "!1.5 Mbps\n"
+ "<1.5Mbps\n"
+ ">1.5Mbps\n"
+ "!1.5Mbps\n\n"
+ "< 1.5 Mbps\n"
+ "< 1.5 M\n"
+ "< 1.5 Kbps\n"
+ "< 1.5 K\n\n\n"
+ "2 Mbps\n"
+ "2Mbps\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}