package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([<>=!]?)\s?((?:\d*\.)?\d+)\s?(.*)$`)
var str = `< 2 Mbps
> 2 Mbps
! 2 Mbps
<2 Mbps
>2 Mbps
!2 Mbps
<2Mbps
>2Mbps
!2Mbps
< 1.5 Mbps
> 1.5 Mbps
! 1.5 Mbps
<1.5 Mbps
>1.5 Mbps
!1.5 Mbps
<1.5Mbps
>1.5Mbps
!1.5Mbps
< 1.5 Mbps
< 1.5 M
< 1.5 Kbps
< 1.5 K
2 Mbps
2Mbps
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}