$re = '/^([<>=!]?)\s?((?:\d*\.)?\d+)\s?(.*)$/m';
$str = '< 2 Mbps
> 2 Mbps
! 2 Mbps
<2 Mbps
>2 Mbps
!2 Mbps
<2Mbps
>2Mbps
!2Mbps
< 1.5 Mbps
> 1.5 Mbps
! 1.5 Mbps
<1.5 Mbps
>1.5 Mbps
!1.5 Mbps
<1.5Mbps
>1.5Mbps
!1.5Mbps
< 1.5 Mbps
< 1.5 M
< 1.5 Kbps
< 1.5 K
2 Mbps
2Mbps
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);