re = /^(?:([\p{Lu}0-9_]{2,})|(\p{Lu}[\p{L}0-9_$]+)|([\p{L}_$][\p{L}0-9_$]*))\b/m
str = 'HELLO
Hello
hello
A
AClass
b
BCONST
$helloWorld
$GoodbyeWorld
$WHATUPWORLD
101Regex
neel@computer.local'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end