using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:([\p{Lu}0-9_]{2,})|(\p{Lu}[\p{L}0-9_$]+)|([\p{L}_$][\p{L}0-9_$]*))\b";
string input = @"HELLO
Hello
hello
A
AClass
b
BCONST
$helloWorld
$GoodbyeWorld
$WHATUPWORLD
101Regex
neel@computer.local";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}