const regex = /^(?:([\p{Lu}0-9_]{2,})|(\p{Lu}[\p{L}0-9_$]+)|([\p{L}_$][\p{L}0-9_$]*))\b/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:([\\p{Lu}0-9_]{2,})|(\\p{Lu}[\\p{L}0-9_$]+)|([\\p{L}_$][\\p{L}0-9_$]*))\\b', 'mg')
const str = `HELLO
Hello
hello
A
AClass
b
BCONST
\$helloWorld
\$GoodbyeWorld
\$WHATUPWORLD
101Regex
neel@computer.local`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}