$re = '/^(?:([\p{Lu}0-9_]{2,})|(\p{Lu}[\p{L}0-9_$]+)|([\p{L}_$][\p{L}0-9_$]*))\b/m';
$str = 'HELLO
Hello
hello
A
AClass
b
BCONST
$helloWorld
$GoodbyeWorld
$WHATUPWORLD
101Regex
neel@computer.local';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);