$re = '/\d+/m';
$str = '7,673,656.87
427,870.27
7,401.38
102,393.11
2,340,692.03
2,093,675.04
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;